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Outline:

1. General-to-Specific (GETS) modelling:
→ Motivation, properties, advantages, disadvantages

2. The basics of OxMetrics 5:
→ Loading, editing and transforming data (logs, differencing),
creating “special” series (cointegration relations, trends, etc.)

3. An overview of Autometrics:
→ Key concepts and characteristics

4. Single-equation modelling with Autometrics
→ Formulation, Advanced Autometrics settings, fixing variables,
example (2007 Econometric Game, Q1)

5. Multiple-equation modelling with Autometrics
→ Formulation, fixing variables, example (2007 Econometric
Game, Q2)
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Common (in-sample) modelling strategies:

1. Select model that minimises information criterion

2. Simple-to-general

3. “1-shot” General

4. Single-path GETS

• Multi-Path GETS: Combines 1 and 4 iteratively

• Multi-Path GETS algorithms: Hoover and Perez (1999), PcGets
(Hendry and Krolzig 2001, 2005), Autometrics (Doornik and
Hendry 2007a, Doornik 2009), AutoSEARCH (Sucarrat and
Escribano 2009, Sucarrat 2009)

• Autometrics: A feature in OxMetrics that automates Multi-Path
GETS



GETS modelling OxMetrics basics Single-equation GETS Multiple-equation GETS References

Autometrics automates GETS modelling of an OLS or IV estimable
linear regression

y = β0 + β1x1 + · · ·+ βKxK + ε

where the {ε} can be homoscedastic, heteroscedastic and/or
autocorrelated

• NOTE: Only the case where {ε} ∼ IIN(0, σ2) has been
extensively studied through Monte Carlo simulation (see in
particular Hendry and Krolzig 2005, and Doornik 2009)

• Analytical analysis either not possible or yields limited insight
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GETS modelling summarised:

1. Formulate a General Unrestricted Model (GUM)

2. Delete step-wise, along different paths, insignificant regressors
at the chosen regressor significance level α (“target size”,
optional), while checking a range of (optional) diagnostics at each
deletion using a different (optional) significance level

3. If simplification results in more than one terminal model, then
select the model with lowest value on the chosen information
criterion (default: Schwartz), or their union (optional)
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Main benefits of GETS modelling:

• Estimation and inference is conducted while controlling for the
influence of other variables

• In simulations multi-path GETS compares favourably to other
(in-sample) modelling strategies

• GETS modelling results in a parsimonious model that is partic-
ularly useful for scenario analysis (conditional forecasting, policy
analysis, counterfactual analysis, etc.)

Main disadvantages of GETS modelling:

• Slight tendency to retain irrelevant variables (the more corre-
lated the regressors, the higher the tendency)

• Finite sample behaviour can depend substantially on the prop-
erties of the data (regressor inter-correlation, homoscedastic vs.
heteroscedastic errors, fat-tailed errors, etc.)
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Define k0 as the number of relevant variables in GUM, k1 as the
number of irrelevant variables in GUM (and so k0 + k1 = K total
number of variables in the GUM):

• k̂0/k0 is the relevance proportion or “potency” (analogous to
“power” in statistical hypothesis testing)

• k̂1/k1 is the irrelevance proportion or “gauge” (analogous to
“size” in statistical hypothesis testing)

Main statistical properties of Autometrics (default options):

• E (k̂0/k0)→ 1 as the sample size goes to ∞

• E (k̂1/k1)→ α as the sample size goes to ∞
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Target size:

• User defined regressor significance level α. For example, if 5% is
chosen, then the insignificant regressors at 5% are deleted

Diagnostic test p-value:

• The acceptable diagnostic test significance level. For example, if
deleting an insignificant variable results in a diagnostic test p-value
above the acceptable level, then the variable is re-included into the
model
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Branch:

• Suppose we choose a regressor significance level of 5%, and
consider the following GUM:

Regressor Coef. P-value

x1 2.851 0.35
x2 0.343 0.00
x3 1.069 0.07

The GUM contains TWO insignificant variables (x1 and x3) ⇒
TWO branches each made up of paths

Path:

• A deletion sequence. For example if x1 is deleted first and then
x3 before no regressors are significant at the chosen regressor
significance level, then {x1, x3} is a deletion path or sequence
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Rounds:

• If simplification results in more than one terminal model, then
Autometrics initiates a second round by forming a new GUM made
up of the union of the terminal models

• Specification search terminates when either only one terminal
model results, or when the GUM at round n equals the GUM at
round n − 1. If this is the case, then a “Tiebreaker” (an
information criterion) is used to select among the models

Backtesting:

• Parsimonious encompassing test. By default, this is a joint test
of the final model against the initial GUM (“GUM 0”), that is, an
F -test of whether the deleted regressors are jointly insignificant at
α
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OxMetrics basics:

• Load data: File → Open, etc.

• Edit sample/dates: Edit → Change Sample

• Missing values (my recommendation): Set to “missing” by
double-clicking the data cell in question

• Graph series: Model → Graphics (or click on the graphics
button) → Actual series or All plot types

• Transform data (algebra feature):

Edit → Algebra (or click on the “Alg” button) →
“Code”, e.g. “DCOO = diff(COO,1);” → Run (→ Done)

(NOTE: Case sensitivity in variable names!)

• Create special series (calculator feature): Model → Calculator
(or click on the calculator button) → . . .
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• Example. Edit dates (2007 Econometric Game Case):
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• Example. Create a differenced series:
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Autometrics is a multi-path GETS modelling feature in OxMetrics:

• The objective of Autometrics is to automate Multi-Path GETS
specification search of a data coherent, General Unrestricted Model
(GUM) in the form of a linear OLS/IV estimable regression (or
regressions)

• Default definition of data-coherency: Stable parameters and
Gaussian, serially uncorrelated, homoscedastic errors. NOTE:
These assumptions can be relaxed through the “Advanced
Autometrics settings”, and if the GUM fails one or several
diagnostic checks Autometrics proceeds anyway

• GUM: A general model (advice: Not too general!) that includes
the variables and lags that are believed to possibly have an impact

• Further reading: Doornik and Hendry (2007a, pp. 70-77),
Hendry and Krolzig (2001) (Autometrics is an evolution of PcGets)
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Single-equation estimation. Example: 2007 Econometric Game,
Question 1

• A “rough” GUM:

∆COOt = b0 + b1∆COOt−1 + b2∆COOt−2 +
11∑
j=1

cjdj ,t + et (1)

• Formulating a model: (Model →) PcGive → Category: “Models
for time series data” → Model class: “Single-equation dynamic
modelling using PcGive” (→ Options) → “Formulate”

• Some estimation options (→ Options):

→ White (1980) standard errors: Tick “Heteroscedasticity con-
sistent standard errors”

→ Newey and West (1987) standard errors: Tick “Heteroscedas-
ticity consistent standard errors” and “HACSE”

→ Selected diagnostic tests: Tick “Test summary”
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• Formulate a model: (Model →) PcGive → Category: “Models
for time series data” → Model class: “Single-equation dynamic
modelling using PcGive” → “Formulate”
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• Estimation options (→ Options):



GETS modelling OxMetrics basics Single-equation GETS Multiple-equation GETS References

• Specify model (. . .→ Formulate):

• “Seasonal”, “CSeasonal”: Seasonal dummies and centred
seasonal dummies, respectively

• Estimate with default options: Ok → Ok → Ok
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Single-equation GETS modelling with Autometrics. Example: 2007
Econometric Game, Question 1

• Recall the “rough” GUM:

∆COOt = b0 + b1∆COOt−1 + b2∆COOt−2 +
11∑
j=1

cjdj ,t + et

• The specific model proposed by Autometrics using the default
options:

∆COOt = b0 + b1∆COOt−1 +
3∑

j=1

cjdj ,t +
11∑
j=5

cjdj ,t + et

• Level representation:

COOt = b0+(1+b1)COOt−1+b1COOt−2+
3∑

j=1

cjdj ,t+
11∑
j=5

cjdj ,t+et
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• Specify model:

USEFUL FEATURE: Fixing regressors (that is, preventing
Autometrics from deleting them). Select the regressors to fix →
Right-click mouse → A: instrument/fixed. NOTE: Do the same
thing to define instruments if IV is used instead of OLS
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• GETS modelling with Autometrics: Tick “Automatic model
selection”
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• Main Autometrics options:

→ Target size: Regressor and backtesting significance level

→ Outlier detection: Neutralises large residuals in the GUM by
means of impulse dummies

→ Pre-search lag reduction: Speeds up simplification; GENERAL
ADVICE: Turn off!

→ Advanced Autometrics settings: Tick if default settings are
unsatisfactory
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• Advanced Autometrics settings:
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• Selected advanced Autometrics settings:

→ Backtesting: “None” may be preferable if the final model does
not encompass the initial GUM. “GUM0” is the initial GUM,
which generally does not correspond to the “Current GUM”

→ Tiebreaker: The information criterion used to select between
terminal models. SC (Schwartz) and min(k) (the model with the
least regressors) are the most conservative

→ Diagnostic test p-value: The acceptable diagnostic test sig-
nificance level. If deleting an insignificant variable results in a
diagnostic test p-value above the acceptable level, then the vari-
able is re-included into the model

→ Standard errors: Ordinary (“Default”), White (1980)
(“HCSE”) and Newey and West (1987) (“HACSE”)

→ Heteroscedasticity tests: White (1980)



GETS modelling OxMetrics basics Single-equation GETS Multiple-equation GETS References

• “Recursive estimation”: Slows down the computations (slightly),
but it enables some very useful recursive stability analysis features

• Specific model proposed by Autometrics:
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Some further diagnostic tests:

• Residuals graphs: Model → Test → Graphical analysis → . . .

• User specified residuals tests: Model → Test → Test → . . .

• Recursive graphics (VERY useful!): Model → Test → Recursive
graphics → . . .
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Single equation dynamic forecasting:

• The parsimonious model suggested to us by Autometrics
contains lags and deterministic terms only, so we may readily
generate dynamic forecasts beyond 2000(12)

• Forecasting DCOO dynamically 24 months beyond 2000(12):
Model → Test → Forecast and then

yields (graph on next slide)
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Single equation dynamic forecasting (cont.):

• Out-of-sample forecasts of DCOO from 2001(1)-2002(12):

• In order to generate forecasts of the level of COO, recall that any
variable yT satisfies yT = y0 +

∑T
t=1 ∆yt . In other words, tick

“Write results instead of graphing” and use Algebra or Calculator
(Model → Calculator) to obtain the forecasts of the levels COO
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Multiple-equation modelling with Autometrics (two approaches):

1. Seemingly Unrelated Regression (SUR) using OLS/IV, that is,
single-equation GETS modelling of each equation separately
(requires stationarity of regressors)

2. Simultaneous variable deletion (or non-deletion) across
equations using vector diagnostic tests but estimation still by OLS
(does not require stationarity of regressors), see Doornik and
Hendry (2007b, pp. 29-31). (NOTE: IV estimation not available
with this strategy)

→ Model type: “Unrestricted system” (system of URFs), see
Doornik and Hendry (2007b, chapter 3)
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Formulate a system: (Model →) PcGive → Category: “Models for
time series data” → Model class: “Multiple-equation dynamic
modelling using PcGive” → “Formulate”
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Multiple-equation modelling with Autometrics using second
approach. Example: 2007 Econometric Game, Question 2

• My GUM: A six-dimensional VAR(2) of
yt = (TEMPt ,COOt ,RADt ,PREt ,VAPt ,CLDt), with a constant
and 11 centered seasonals in each of the six equations:



GETS modelling OxMetrics basics Single-equation GETS Multiple-equation GETS References

• Fixing variables (that is, restricting Autometrics to keep them)
now differs:

� Fixing VAR-lags is not possible, only the exogenous regressors
can be fixed

� Select the exogenous regressors to fix → Right-click mouse →
U: Unrestricted

� To unfix exogenous regressors, select the regressors to unfix→
Right-click mouse → Clear status

• Lag-deletion is undertaken across equations. For example,
TEMP1 is either deleted from all six equations or from none, etc.
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Results with default settings:

• NOTE: Autometrics simplifies even though the GUM does not
pass all diagnostic checks

• Four variables are removed from all of the equations: The second
lag of TEMP, VAP and CLD, and CSeasonal 10

Other type of analysis:

• Cointegration analysis (applied on the Unrestricted system, not
on the simplified model): Model → Test → Dynamic Analysis and
Cointegration Tests → . . .

See Doornik and Hendry (2007b, chapter 4)
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